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What Are the Windows Help Authoring Templates?
The Windows Help Authoring Templates (WHAT30.DOT and WHAT31.DOT) are document 
templates that modify Word for Windows. You can use the Help Authoring Templates to 
create and edit Help topic files. The Help Authoring Templates make creating Help files 
easier by providing dialog boxes to add Help features that would normally be created using 
specialized Help coding and word-processing functions. For example, instead of entering 
footnotes for a topic's context string and title, you can simply type the information in a 
dialog box.
The Help Authoring Templates make it easier for you to:

Create and edit topic files.
Insert and edit topics, graphics, and hot spots.
Format topic text and graphics.
Save topic files in RTF format.
View partial or complete builds of the topic file in Windows Help.



How the Help Authoring Templates Work
The Help Authoring Templates are similar to other Word for Windows templates: they 
contain a set of specialized macros and styles that become available when you open a 
document based on the template. The templates modify existing commands and add new 
commands to the Word for Windows menus. The result is a version of Word for Windows 
that has all the word-processing functionality and yet is optimized for creating Help files.
Because Windows Help version 3.1 offers more features than version 3.0, Microsoft 
provides a separate template for each version of Windows Help. If you plan to create a Help
system that runs under Windows Help version 3.1, use the 3.1 template (WHAT31.DOT). 
Help version 3.0 files, on the other hand, use WHAT30.DOT as the authoring template.
If you are using the Help Project Editor along with the Help Authoring Templates, the 
document template applied to your topic files is determined by two things: the version of 
Word for Windows you have installed on your hard disk drive and the version of Help you 
are using to build this Help file. 
Based on those choices, the Help Project Editor automatically applies the correct template 
to your topic files when you edit them using the Help Project Editor. Therefore, if you want 
to start a Help project using Help 3.0 and then switch to Help 3.1 later, you simply select 
that option in the Project dialog box and the 3.1 template will be applied to your topic files 
the next time you edit them in Word for Windows.



The Template Macros
The Help Authoring Templates include macros that modify the functionality of Word for 
Windows to improve its use as a Help authoring tool. To make the macros easy to use, they 
have been attached to menu commands. The primary objective in creating the macros is to
provide software developers and new Help authors a faster and better way to create Help 
files. However, the macros included represent the minimum set necessary for creating Help
files. They do not provide a shortcut method for authoring every available feature, nor do 
they replace an understanding of Windows Help functionality and how to author without 
using the templates. For that reason, Help authors are encouraged to modify the existing 
macros and create new macros to meet their specific authoring requirements.
To use the macros, create a new Help topic file and base it on WHAT30.DOT or 
WHAT31.DOT. The macros are then available as menu commands. When using the macros, 
the templates attempt to restore Word for Windows to its state before the macro executed. 
If the window was split, for example, the template attempts to restore the split panes after 
running the macro.
The following table shows the complete list of macros included in the templates and the 
menu commands that activate them.

Macro function Attached to command
Create new topic file File New
Open topic file File Open
Save topic file File Save
Save topic file with new 
name

File Save As

Edit topic footnotes Edit Topic
Edit hot-spot information Edit Hot Spot
Edit bitmap reference Edit Graphic
Build current topic View Topic
Build topic file View File
Build current selection View Selection
Add new topic Insert Topic
Insert jump or pop-up Insert Jump or Pop-Up Hot 

Spot
Insert Help macro Insert Macro Hot Spot
Insert bitmap reference Insert Graphic

The Template Style Sheet
The style sheet included with the Help Authoring Templates contains the standard styles 
Microsoft recommends for creating Help files. They are provided to Help authors to enable 
them to format all the text and graphic elements of a Help file without having to go through
the time and effort of creating a style sheet from scratch. Of course, the existing styles can 
be modified and additional styles can be created if your Help system requires those 
changes. But these styles should provide a good starting place for any style sheet, no 
matter how sophisticated. 
The following table describes each style included in the style sheet.



Style Definition Used for
bitmap Font: MS Sans Serif (or Helv) 10 

Point, Indent: Left 6pt Flush left, 
Line Spacing Auto, Space Before 6 
pt After 6 pt, Next style: Normal

Bitmaps that 
occur alone in a 
paragraph

Ex Font: Courier (or Letter Gothic) 8 
Point, Indent: Left 6pt Flush left, 
Line Spacing: Exactly 12pt, Space 
Before 3pt, Keep Lines Together, 
Tab stops: 26pt; 46pt; 66pt; 86pt; 
106pt, Next style: Ex

Programming 
code examples 
and ASCII text

heading 
1

Font: MS Sans Serif (or Helv) 12 
Point, Bold, Indent: Left 6pt Flush 
left, Line Spacing: -16pt, Space 
Before 14pt, After 6pt, Next style: 
Normal 2

Topic titles

heading 
2

Font: MS Sans Serif (or Helv) 10 
Point, Bold, Indent: Left 6pt Flush 
left, Line Spacing: Exactly 12pt, 
Space Before 6pt After 3pt, Next 
style: Normal

Bold subheadings 
(procedures, 
notes, comments,
hints, tips, and 
examples)

heading 
3

Font: MS Sans Serif (or Helv) 10 
Point, Indent: Left 6pt Flush left, 
Line Spacing: Exactly 12pt, Space 
Before 6pt After 3pt, Next style: 
Normal

Plain subheadings
(procedures, 
notes, comments,
hints, tips, and 
examples)

heading 
4

Font: MS Sans Serif (or Helv) 10 
Point, Indent: Left 18pt First -
12.25pt Flush left, Line Spacing: 
Exactly 12pt, Space Before 6pt 
After 3pt, Next style: Normal

Plain procedure 
heading used 
with dingbat

Jl Font: MS Sans Serif (or Helv) 10 
Point, Indent: Left 18pt First -12pt 
Flush left, Line Spacing: Exactly 
12pt, Space Before 3pt, Next style:
Jl

Lists of jumps

Jli Font: MS Sans Serif (or Helv) 10 
Point, Indent: Left 30pt First -12pt 
Flush left, Line Spacing: Exactly 
12pt, Space Before 3pt, Next style:
Jli

Indented lists of 
jumps

Lb1 Font: MS Sans Serif (or Helv) 10 
Point, Indent: Left 18pt First -12pt 
Flush left, Line Spacing: Exactly 
12pt, Tab stops: 18pt, Next style: 
Lb2

The first item in a 
bulleted or 
numbered list

Lb2 Font: MS Sans Serif (or Helv) 10 
Point, Indent: Left 18pt First -12pt 
Flush left, Line Spacing: Exactly 
12pt, Space Before 3pt, Tab stops: 

Succeeding items 
in a bulleted or 
numbered list



18pt, Next style: Lb2
Lp1 Font: MS Sans Serif (or Helv) 10 

Point, Indent: Left 18pt Flush left, 
Line Spacing: Exactly 12pt, Space 
Before 3pt, Next style: Lb2

Paragraphs within
a bulleted or 
numbered list

Normal Font: MS Sans Serif (or Helv) 10 
Point, Indent: Left 6pt Flush left, 
Line Spacing: Exactly 12pt, Space 
Before 4pt, Next style: Normal

Body text

Normal 2 Font: MS Sans Serif (or Helv) 10 
Point, Indent: Left 6pt Flush left, 
Line Spacing: Exactly 12pt, Next 
style: Normal

Paragraphs 
following topic 
titles

Normal 3 Font: MS Sans Serif (or Helv) 10 
Point, Indent: Left 5.75pt Flush left,
Line Spacing: Exactly 12pt, Space 
Before 10pt, Next style: Normal

Paragraphs used 
in a nonscrolling 
region

Normal 
Indent

Font: MS Sans Serif (or Helv) 10 
Point, Indent: Left 18pt Flush left, 
Line Spacing: Exactly 12pt, Space 
Before 4pt, Next style: Normal

Indented 
paragraphs

Sa1 Font: MS Sans Serif (or Helv) 10 
Point, Indent: Left 6pt Flush left, 
Line Spacing: Exactly 12pt, Space 
Before 8pt, Next style: Jl

"See Also" 
subheadings

Sa2 Font: MS Sans Serif (or Helv) 10 
Point, Indent: Left 6pt Flush left, 
Line Spacing: Exactly 12pt, Space 
Before 6pt, Next style: Jl

Subheadings 
below "See Also" 
subheading

Th Font: MS Sans Serif (or Helv) 10 
Point, Bold, Indent: Left 5.75pt 
Flush left, Line Spacing: Exactly 
12pt, Space Before 6pt After 2pt, 
Border: Bottom(Single), Next style:
Tp

Subheadings for 
two-column lists 
and tables

Thh Font: MS Sans Serif (or Helv) 10 
Point, Bold, Indent: Left 96pt First -
90pt Flush left, Line Spacing: 
Exactly 12pt, Space Before 6pt 
After 2pt, Border: Bottom (Single) 
Tab stops: 96pt, Next style: Tph

Subheadings for 
hanging-indent 
tables

Tp Font: MS Sans Serif (or Helv) 10 
Point, Indent: Left 5.75pt Flush left,
Line Spacing: Exactly 12pt, Space 
Before 3pt, Next style: Tp

Paragraphs within
two-column lists 
and tables

Tph Font: MS Sans Serif (or Helv) 10 
Point, Indent: Left 96pt First -90pt 
Flush left, Line Spacing: Exactly 
12pt, Space Before 3pt, Tab stops: 
96pt, Next style: Tph

Paragraphs within
hanging-indent 
tables



Adding Graphics to Help Topics
To use graphics in your Help file, you can paste the graphics directly into the topic or use a 
bitmap reference that tells the Help compiler which graphic to display and how to align it in
the topic. The Help Authoring Templates make it easy to add graphics as bitmap references.
To insert a bitmap reference
1 From the Insert menu, choose Graphic.

The Insert Graphic dialog box appears.
2 Type the name of the bitmap file in the File Name box.

Note: Although this entry is required, the template does not check for the existence of 
the bitmap name or for correct syntax. It does check for illegal characteristics, however.

3 Choose the type of alignment you want to use for the graphic.
4 If you want this graphic to function as a hot spot, choose the hot-spot type.
5 Choose OK.

If you choose any hot-spot type other than Not A Hot Spot, you will see the appropriate 
hot-spot dialog box.

See Also
Editing Graphic Information
Editing Hot-Spot Information
Insert Graphic Command



Adding Jumps and Pop-Up Windows to Help Topics
You can add hot spots to text or graphics in your Help topics.
To create a jump or pop-up hot spot
1 Select the text or graphic that you want to use to create the hot spot.

Be careful not to select any part of the topic that you do not want to include in the hot 
spot.

2 From the Insert menu, choose Jump Or Pop-Up Hot Spot.
The Insert Jump Or Pop-Up Hot Spot dialog box appears.

3 Edit the text in the Text box, if necessary.
If you select text or a bitmap reference before choosing the command, the selected text 
appears in the Text box when the dialog box opens. If you select a picture that has been 
pasted into the topic, the message "--Picture Hot Spot--" replaces the Text box since the 
picture has no text and cannot be edited.
Note: Although this entry is required, the template does not check the text or bitmap 
name for correctness.

4 Type the context string of the destination topic.
Note: Although this entry is required, the template does not check for the existence of 
the context string or for correct syntax. It does check for illegal characteristics, however.

5 Select the type of hot spot you want to create.
6 Select the Unformatted check box if you want the hot spot to appear as authored (no 

underline, custom color) rather than the standard underlined-green text.
7 If the jump is to a topic in a separate Help file, type the name of the Help file in the File 

Name box.
Note: These jumps do not include jumps to topics in any topic file included in the current 
Help project file.

8 If the jump is to a topic that you want displayed in a secondary window, type the name of
the secondary window in the Window Name box.
Note: A pop-up window cannot be displayed in a secondary window. If you choose Pop-Up
as the hot-spot type and try to enter a name here, a dialog box appears and prompts you
to choose between a pop-up or secondary window.

9 Choose OK.
See Also
Editing Hot Spot Information
Insert Jump or Pop-Up Hot Spot Command



Adding Macro Hot Spots to Help Topics
Windows Help version 3.1 offers the option of adding macro hot spots to Help topics, in 
addition to the standard jump or pop-up hot spots.
To create a macro hot spot
1 Select the text or graphic that you want to use to create the hot spot.

Be careful not to select any part of the topic that you do not want to include in the hot 
spot.

2 From the Insert menu, choose Macro Hot Spot.
The Insert Macro Hot Spot dialog box appears.

3 Edit the text in the Text box, if necessary.
If you select text or a bitmap reference before choosing the command, the selected text 
appears in the Text box when the dialog box opens. If you select a picture that has been 
pasted into the topic, the message "--Picture Hot Spot--" replaces the Text box since the 
picture has no text and cannot be edited.

4 Select the macro from the list box that you want Windows Help to execute when the user
chooses the hot spot.
Or type the macro name in the Macro box.
Note: The list box includes all valid macro names, including abbreviations.

5 Type the appropriate parameters for the macro you selected.
Note: If you want to enter a complex macro string for this hot spot, you must type the 
additional macros and parameters by hand.

6 Select the Unformatted check box if you want the macro hot spot to appear as authored 
(no underline, custom color) rather than the standard underlined-green text.

7 Choose OK.
See Also
Editing Hot-Spot Information
Insert Macro Hot Spot Command



Adding New Topics
When you create a Help topic file, you add all the topics that you want included in the build
of the Help file.
To add a topic to the Help topic file
1 From the Insert menu, choose Topic.

The Insert Topic dialog box appears. The text boxes in the dialog box represent the topic 
footnotes supported by the Help compiler.

2 In the Title box, type the title that you want to give this topic.
3 In the Context String box, type the context string that you want to assign to this topic.
4 In the Keywords box, type the keywords that you want users to use to find this topic in a 

keyword search.
Keywords must be entered in this text box exactly as they would be entered in a footnote
window. You must separate each keyword with a semicolon.

5 In the Browse Sequence box, type the list name and/or sequence number if this topic is 
to be included in a browse sequence.

6 In the Build Tag box, type the build tag you want to assign to this topic, if you are using 
build tags. You must separate each build tag with a semicolon.

7 In the Entry Macro box, type the macro string that you want Windows Help to execute 
when the user jumps to this topic.

8 In the Comment box, type any optional comments that you want to include with this 
topic.
The Help Authoring Templates use the at sign (@) as the footnote character for comment
text you enter here.
Note: These comments are ignored by the Help compiler.

9 Select Place New Topic At End Of File if you want the new topic added at the end of the 
topic file.
Note: Unless you select this check box, the Help Authoring Templates add new topics 
immediately before the current topic. (The current topic is the topic where the insertion 
point is located, even if the insertion point is at the beginning of the file.) If this is the 
first topic you are adding to the file, no page break is inserted after the topic information.

10 Choose OK.
See Also
Editing Topic Information
Insert Topic Command



Creating New Help Topic Files
To create a new Help topic file
1 From the File menu, choose New.
2 In the Use Template box, select the authoring template to use for this topic file.
Note: The authoring template should correspond to the version of Help you want to build.
3 In the New box, select Document as the type of file.
4 Choose OK.
See Also
New Command
Opening Existing Help Topic Files



Displaying Topics in Windows Help
If you want to check the progress of your work, you can use the Help Authoring Templates 
to create a Help file from the topics you are working on and display the built file in Windows
Help. You can create this temporary Help file of the entire topic file, a portion of the topic 
file, a single topic, or a selection within a topic.
To view a compiled version of the current topic file

From the View menu, choose File.
If the topic file includes graphics, you may be prompted to give the bitmap directory.
To build the file, the template creates the temporary files TEMP.RTF and TEMP.HPJ. When 
the file is built, the template starts Windows Help and opens TEMP.HLP, which contains 
the entire topic file, a single topic, or a selection from a topic.

To view a compiled version of the current topic
1 Place the cursor within the topic you want to view.
2 From the View menu, choose Topic.

If the topic includes graphics, you may be prompted to give the bitmap directory.
To view a compiled version of a partial topic file
1 Select the portion of the topic file you want to view.
2 From the View menu, choose Selection.

If the topic file includes graphics, you may be prompted to give the bitmap directory.
See Also
View File Command
View Selection Command
View Topic Command



Editing Graphic Information
If you added graphics to your Help topics using bitmap references, you can edit this 
information.
To edit a bitmap reference
1 Select the bitmap reference that you want to edit.

You can select all or part of the bitmap reference, or you can simply place the insertion 
point within the bitmap reference. But do not select any other text or you will create an 
error.

2 From the Edit menu, choose Graphic.
The Edit Graphic dialog box appears.

3 Edit the name of the bitmap file in the File Name box, if necessary.
The text of the bitmap reference you selected before choosing this command appears in 
the File Name box when the dialog box opens.
Note: Although this entry is required, the template does not check for the existence of 
the bitmap name or for correct syntax. It does check for illegal characteristics, however.

4 Select the type of alignment you want to use for the graphic.
5 If you want this graphic to function as a hot spot, select the hot-spot type.
6 Choose OK.

If you change the graphic from not hot to hot or from one hot-spot type to another, the 
template displays the appropriate hot-spot dialog box so you can enter hot-spot 
information. If you change the graphic from hot to not hot, the hot-spot formatting is 
removed from the bitmap reference.

See Also
Adding Graphics to Help Topics
Edit Graphic Command



Editing Hot-Spot Information
You can edit hot-spot information for jumps, pop-up windows, and macros. Because this 
information is significantly different depending on the type of hot spot, the Help Authoring 
Templates use two dialog boxes: one for jump and pop-up hot spots and one for macro hot 
spots.
To edit a jump or pop-up hot spot
1 Select the hot spot that you want to edit.

You can select all or part of the hot spot, or you can simply place the insertion point 
within the hot spot. But do not select any text outside the hot spot or you will create an 
error.

2 From the Edit menu, choose Hot Spot.
The Edit Jump Hot Spot or Edit Pop-Up Hot Spot dialog box appears.
Note: The Help Authoring Templates determine which caption to display in the dialog box
by the formatting of the text or graphic you selected. If the hot spot has single 
underlining, the template displays "Edit Pop-Up Hot Spot"; if it has double underlining, 
the template displays "Edit Jump Hot Spot."

3 Edit the text in the Text box, if necessary.
If you select text or a bitmap reference before choosing the command, the selected text 
appears in the Text box when the dialog box opens. If you select a picture that has been 
pasted into the topic, the message "--Picture Hot Spot--" replaces the Text box since the 
picture has no text and cannot be edited.
Note: Although this entry is required, the template does not check the text or bitmap 
name for correctness.

4 Edit the context string of the destination topic.
Note: Although this entry is required, the template does not check for the existence of 
the context string or for correct syntax. It does check for illegal characteristics, however.

5 Select the type of hot spot you want.
6 Select the Unformatted check box if you want the hot spot to appear as authored (no 

underline, custom color) rather than the standard underlined-green text.
7 If the jump is to a topic in a separate Help file, type the name of the Help file in the File 

Name box.
8 If the jump is to a topic that you want displayed in a secondary window, type the name of

the secondary window in the Window Name box.
Note: A pop-up window cannot be displayed in a secondary window. If you select Pop-Up 
as the hot-spot type and try to enter a name here, a dialog box appears and prompts you
to choose between a pop-up or secondary window.

9 Choose OK.

To edit a macro hot spot
1 Select the macro hot spot that you want to edit.

You can select all or part of the macro hot spot, or you can simply place the insertion 
point within the macro hot spot. But do not select any text outside the hot spot or you 
will create an error.

2 From the Edit menu, choose Hot Spot.
The Edit Macro Hot Spot dialog box appears.
Note: The Help Authoring Templates display this dialog box if the hidden text in the hot 
spot begins with an exclamation point (!), the symbol used to indicate a macro hot spot.



3 Edit the text in the Text box, if necessary.
If you select text or a bitmap reference before choosing the command, the selected text 
appears in the Text box when the dialog box opens. If you select a picture that has been 
pasted into the topic, the message "--Picture Hot Spot--" replaces the Text box since the 
picture has no text and cannot be edited.
Note: Although this entry is required, the template does not check the text for 
correctness.

4 Edit the macro string in the Macro box.
Or select a different macro from the list box.
Note: Although this entry is required, the template does not check for the existence of 
the macro string or for correct syntax. It does check for illegal characteristics, however.
Note: If you want to enter a complex macro string for this hot spot, you must type the 
additional macros and parameters by hand.

5 Select the Unformatted check box if you want the hot spot to appear as authored (no 
underline, custom color) rather than the standard underlined-green text.

6 Choose OK.
See Also
Adding Jumps and Pop-Up Windows to Help Topics
Adding Macro Hot Spots to Help Topics
Edit Hot Spot Command



Editing Topic Information
You can edit any topic in the file whether or not you created it using the Help Authoring 
Templates.
To edit a topic's footnote information
1 Place the insertion point anywhere inside the boundaries of the topic you want to edit.

Note: Because Help topics are separated by page breaks, the current topic is defined by 
everything that appears between two page breaks.

2 From the Edit menu, choose Topic.
The Edit Topic dialog box appears; any information previously entered in the topic is 
displayed in the appropriate text boxes.
Note: Information in footnotes not at the beginning of the topic or not supported by the 
Help compiler do not appear in the dialog box.

3 Edit the information displayed in the Title, Context String, Keywords, Browse Sequence, 
Build Tag, Entry Macro, and Comment boxes.
Or type the appropriate information if the box is empty and you are adding the feature.
Note: Keywords must be entered in this text box exactly as they would be entered in a 
footnote window. You must separate each keyword with a semicolon.
Note: The Help Authoring Templates use the at sign (@) as the footnote character for 
comment text you enter here.

4 Choose OK.
See Also
Adding New Topics
Edit Topic Command



Opening Existing Help Topic Files
You can open any Help topic file, whether or not you have used the Help Authoring 
Templates to create it.
To open a Help topic file
1 From the File menu, choose Open.

The Open dialog box appears.
2 If the file is on a different drive, select the drive you want from the Drives box.
3 In the Directories box, double-click the directory you want.    

Or press the UP ARROW or DOWN ARROW key to select the directory, and then press ENTER.
4 In the File Name box, double-click the name of the file you want to open.    

Or select the file and choose OK.
See Also
Creating New Help Topic Files
Open Command



hint
Windows displays the names of all files in that directory that are the type selected in the 
List Files Of Type box. To select a different file type, use the List Files Of Type list box.



hint
The current directory is represented by the open folder icon.
Instead of using the File Name and Directories list boxes to add a file, you can type the 
complete path in the File Name box and click OK.



Saving Help Topic Files
Use the Save command to save changes to an existing Help topic file. Use the Save As 
command to save a new (untitled) Help topic file or to rename the current file under a new 
name.
To save changes to an existing Help topic file

From the File menu, choose Save.
Note: The Help Authoring Templates save topic files in .RTF format rather than the Word for 
Windows standard .DOC format.

To save a new Help topic file or save the current file under a different name
1 From the File menu, choose Save As.

The Save As dialog box appears.
2 If you want to save the file on a different drive, select the drive you want from the Drives

box.
3 In the Directories box, double-click the directory in which you want to save the file.    

Or press the UP ARROW or DOWN ARROW key to select the directory, and then press ENTER.
4 In the File Name box, type a name for the file.    

The .RTF extension is automatically assigned to the filename if you don't specify an 
extension. If you specify an extension, it overrides any automatic extension.

5 Choose OK.
See Also
Save As Command
Save Command



hint
The current directory is represented by the open folder icon.



hint
Instead of using the File Name and Directories list boxes to save a file, you can type the 
complete path in the File Name box and click OK.



File Menu Commands
Choose the command you want Help on.
Commands
New Command
Open Command
Save Command
Save As Command



New Command
Creates a new, untitled topic file or template.
When you create a new topic file, it is based on one of the Help Authoring Templates 
instead of the Word for Windows NORMAL.DOT default template.
See Also
Creating New Help Topic Files



Open Command
Opens an existing Help topic file or template.
When you choose this command, the Help Authoring Templates assume the file type is .RTF
rather than the Word for Windows standard .DOC format.
See Also
Opening Existing Help Topic Files



Save Command
Saves changes to the current Help topic file.
If the Help topic file is untitled, the Help Authoring Templates prompt you for a name.
Note: The Help Authoring Templates save topic files in .RTF format rather than the Word for 
Windows standard .DOC format.
See Also
Saving Help Topic Files



Save As Command
Saves the current Help topic file under a new name.
Note: The Help Authoring Templates use the .RTF extension as the default extension rather 
than the Word for Windows standard .DOC extension.
See Also
Saving Help Topic Files



Edit Menu Commands
Choose the command you want Help on.
Commands
Edit Topic Command
Edit Hot Spot Command
Edit Graphic Command



Edit Topic Command
Displays Help topic information in a dialog box so you can edit it.
You can use this command whether the topic actually contains footnotes or if you used 
another editor to add the footnotes to the topic.
Note: The Help Authoring Templates ignore any footnotes not at the beginning of the topic 
or not supported by the templates, including all MULTIKEY footnotes.
See Also
Adding New Topics
Editing Topic Information
Insert Topic Command



Edit Hot Spot Command
Displays information about a hot spot in a dialog box so you can edit it.
If you have not selected a hot spot before choosing this command, you will see an error 
message.
See Also
Adding Jumps and Pop-Up Windows to Help Topics
Adding Macro Hot Spots to Help Topics
Editing Hot-Spot Information
Insert Jump or Pop-Up Hot Spot Command
Insert Macro Hot Spot Command



Edit Graphic Command
Displays information about a bitmap reference so you can edit it.
You can select all or part of the bitmap reference before you choose the command, but do 
not select any other text or you will create an error.
See Also
Adding Graphics to Help Topics
Editing Graphic Information
Insert Graphic Command



View Menu Commands
Choose the command you want Help on.
Commands
View Topic Command
View File Command
View Selection Command



View Topic Command
Builds the current topic as a Help file and then displays the resulting file in Windows Help.
See Also
Displaying Topics in Windows Help



View File Command
Builds the entire topic file as a Help file and then displays the resulting file in Windows 
Help.
See Also
Displaying Topics in Windows Help



View Selection Command
Builds the text and graphics you selected and then displays the resulting Help file in 
Windows Help.
See Also
Displaying Topics in Windows Help



Insert Menu Commands
Choose the command you want Help on.
Commands
Insert Topic Command
Insert Jump or Pop-Up Hot Spot Command
Insert Macro Hot Spot Command
Insert Graphic Command



Insert Topic Command
Adds a new Help topic to the topic file.
The Help Authoring Templates add new topics at the end of the topic file, or immediately 
before the current topic. (The current topic is the topic where the insertion point is located, 
even if the insertion point is at the beginning of the file.) If you want to insert the new topic
in a specific place, be sure the insertion point is positioned properly before you choose this 
command.
If this is the first topic you are adding to the file, no page break is inserted after the topic 
information.
See Also
Adding New Topics
Edit Topic Command
Editing Topic Information



Insert Jump or Pop-Up Hot Spot Command
Inserts a jump or pop-up hot spot in the Help topic.
Note: Be careful not to select any part of the topic that you do not want to include in the 
hot spot.
Note: This command is Insert Hotspot in WHAT31.DOT.
See Also
Adding Jumps and Pop-Up Windows to Help Topics
Adding Macro Hot Spots to Help Topics
Edit Hot Spot Command
Editing Hot-Spot Information



Insert Macro Hot Spot Command
Inserts a macro hot spot in the Help topic.
Note: Be careful not to select any part of the topic that you do not want to include in the 
hot spot.
Note: This command is only in WHAT31.DOT.
See Also
Adding Jumps and Pop-Up Windows to Help Topics
Adding Macro Hot Spots to Help Topics
Edit Hot Spot Command
Editing Hot-Spot Information



Insert Graphic Command
Inserts a bitmap reference in the Help topic.
See Also
Adding Graphics to Help Topics
Edit Graphic Command
Editing Graphic Information



Help Authoring Template Keys
Use the following keys in the Help Authoring Templates.

To Press
Open an existing topic file CTRL+F12
Save a topic file SHIFT+F12
Save a topic file under a new name F12




